VPN: Keine Geräte im Heimnetzwerk zu finden

Support für das easy2connect System
Antworten
HeikoPh
Beiträge: 1
Registriert: Di 24. Sep 2019, 19:43

VPN: Keine Geräte im Heimnetzwerk zu finden

Beitrag von HeikoPh » Di 24. Sep 2019, 19:54

Hallo,

ich habe seit heute die easy2connect-Box am laufen. Jetzt habe ich VPN aktiviert. Nach der Einwahl am Mac mit dem VPN der easy2connect-Box kann ich keine Geräte im heimischen Netzwerk finden. Über deren Netzwerknamen kann ich die Geräte (z.B. meine NAS) nicht ansprechen, da es sie anscheinend im VPN nicht geibt. Was mache ich falsch?

AndreRose
Beiträge: 64
Registriert: Do 25. Okt 2018, 09:38

Re: VPN: Keine Geräte im Heimnetzwerk zu finden

Beitrag von AndreRose » Do 10. Okt 2019, 11:34

Der IP Adressbereich passt aber wohl?
Finden Sie die Geräte übeer IP? (ping,...)
mfg
André Rose

Friese
Beiträge: 3
Registriert: Mo 14. Okt 2019, 22:18

Re: VPN: Keine Geräte im Heimnetzwerk zu finden

Beitrag von Friese » Mo 14. Okt 2019, 22:54

Ich hänge mich mal hier dran, weil ich vermutlich das gleiche Problem habe (zumindest wenn ich den OP richtig verstehe).

Ich habe mir aus einem alten Raspi2 eine FIP-Box gemacht, um eine VPN-Verbindung in mein Heimnetz u realisieren. Aktuell bin ich noch an einem IPv4-DSL-Anschluß aber bald gibts (hoffentlich) Glasfaser mit DS Lite. Das VPN funktioniert, ich kann meine Geräte im Heimnetz allerdings nur über die IP-Adresse ansprechen. Die lokale Namensauflösung klappt nicht. Im Client-Log sehe ich, dass die Google DNS (8.8.8.8, 8.8.4.4) gepusht werden.

In der /etc/openvpn/server.conf sind die Google-DNS eingetragen (push "dhcp-option DNS 8.8.8.8" push "dhcp-option DNS 8.8.4.4"). Wenn ich dort meine Fritzbox eintrage, stehen dort nach einem reboot wieder die Google DNS. Wie kann ich das denn persistieren? Damit müsste es doch gehen, oder?

Friese
Beiträge: 3
Registriert: Mo 14. Okt 2019, 22:18

Re: VPN: Keine Geräte im Heimnetzwerk zu finden

Beitrag von Friese » Di 15. Okt 2019, 21:34

So, ich bin einen Schritt weiter. der Pi legt anscheinend eine Ramdisk an, aus der alle relevanten Informationen gelesen werden. Bei jedem Reboot wird dann /etc/openvpn neu von der SD-Karte kopiert. So ist die Änderung nicht persistent, wenn man sie in /etc/openvpn (auf der Ramdisk) durchführt. Ein gutes Vorgehen, wenn man verhindern will, dass halbwissende Linuxnoobs wie ich damit rumspielen, so ist nach ein em Reboot immer wieder alles beim Alten.

Auf der SD-Karte habe ich dann unter rootfs/tmp/easy2connect/openvpn auch eine server.conf gefunden. Ändere ich darin allerdings die DNS-Einstellungen, sind auch die nach einem Neustart des Pi wieder auf Google DNS. Ich verzweifle hier grad, kann mich jemand mit etwas mehr Linux- oder Pi-Know-How mal erleuchten? Es muss doch möglich sein, den DNS-Eintrag auf seine Fritzbox zu richten.

Friese
Beiträge: 3
Registriert: Mo 14. Okt 2019, 22:18

Re: VPN: Keine Geräte im Heimnetzwerk zu finden

Beitrag von Friese » Do 17. Okt 2019, 17:58

So, ich habe die Lösung jetzt in einem 3 Jahre alten Post gefunden: viewtopic.php?f=11&t=156
Also immer schön manuell die Client-Config editieren als einmal den Server... Nicht die eleganteste Lösung, aber es funktioniert. Sowas könnte man echt mal sticky machen, das hätte mir so manche Stunde Bastelei erspart.

Antworten