VPN Perfomance

Support für das easy2connect System
Antworten
goetzy
Beiträge: 10
Registriert: Di 13. Mär 2018, 18:18

VPN Perfomance

Beitrag von goetzy » Mo 26. Mär 2018, 10:38

Hallo zusammen,

bin seit einigen Tage Besitzer einer easy2connect Box und wunder mich ein wenig über die VPN Performance durch den Tunnel...

Hatte zwar schon gelesen dass dies auch teilweise an der eingesetzten Hardware liegt, diese ist aber bei weitem nicht ausgelastet!

Beim Download einer knapp 2 GB großen Datei (von einem NAS Server zu Hause) habe ich im Durchschnitt knapp 700 KB/s (5,6 MBit/s) und sehe auf dem Raspberry Pi 3B+ 2 Task's "openvpn" mit jeweils knapp 14 - 18 % CPU Last. Die daraus resultierende Übertragungsgeschwindigkeit erscheint mit etwas wenig, wobei die Leitungen weit aus mehr können und der Raspberry Pi sich langweilt...

zu Hause:
Hardware: Raspberry Pi 3B+ (4 x 1,4 GHz)
Anbindung: Deutsche Glasfaser FTTH (200 MBit synchron)

VPN Client:
Anbindung: Unitymedia (2 x 300 MBit down / 20 MBit up)

ping -4 vpn1-dual.connect2any.net
PING vpn1-dual.connect2any.net (84.200.67.221) 56(84) bytes of data.
64 bytes from 84.200.67.221 (84.200.67.221): icmp_seq=1 ttl=55 time=7.23 ms
64 bytes from 84.200.67.221 (84.200.67.221): icmp_seq=2 ttl=55 time=7.17 ms
64 bytes from 84.200.67.221 (84.200.67.221): icmp_seq=3 ttl=55 time=7.14 ms
64 bytes from 84.200.67.221 (84.200.67.221): icmp_seq=4 ttl=55 time=7.06 ms
64 bytes from 84.200.67.221 (84.200.67.221): icmp_seq=5 ttl=55 time=7.02 ms
64 bytes from 84.200.67.221 (84.200.67.221): icmp_seq=6 ttl=55 time=7.13 ms

Woran kann die geringe Performance liegen? Gibt es seitens Feste-IP eine Limitierung?

Danke für eure Mühe!

Gruß
goetzy
Zuletzt geändert von goetzy am Mi 28. Mär 2018, 12:54, insgesamt 1-mal geändert.

MichaelWeigel
Beiträge: 405
Registriert: Di 24. Feb 2015, 11:13

Re: VPN Perfomance

Beitrag von MichaelWeigel » Di 27. Mär 2018, 17:18

Hallo,

bei Feste-IP gibt es keine Limitierung. Alle Server sind mit je 1GB ans Internet angeschlossen und diese Verbindungen sind nicht ausgelastet.
bei unseren Test mit einer Synchonen 50Mbit Leitung (Rein und Raus am gleichen Anschluss) sind wir auf einen Durchsatz von mind. 10-12 MBit gekommen.
Diese schlechte VPN Performance kommt meist von IPv6 Verbindungs-Problemen bei Unitymedia. (verlorene Pakete). Da beim Client VPN ein VPN im VPN ist, schlagen sich diese Paketverluste doppelt zu Buche.

Wir sind gerade Dabei noch einige Testtools in unser System einzubauen, damit diese Probleme ordentlich erkannt werden können.

LG Michael

goetzy
Beiträge: 10
Registriert: Di 13. Mär 2018, 18:18

Re: VPN Perfomance

Beitrag von goetzy » Mi 28. Mär 2018, 12:06

Hallo Michael,

ich habe mal ein paar Tests durchgeführt um der Ursache auf die Schliche zu kommen...

Auf dem Raspbberry Pi 3B+ laufen bei einer aktiven VPN Verbindung zwei "openvpn" Tasks (ein OpenVPN Tunnel zu Feste-IP und einer zu meinem Client), jeder aber auf einem eigenen CPU Kern, heißt max 100% CPU Last pro OpenVPN Verbindung...

Wie oben beschrieben bekommen ich bei einem Datentransfer (http Download, rsync, AFP Verbindung zu meinem NAS) knapp 700 KByte/s hin, auf meinem Pi erzeugt dies knapp 14 % CPU Last.

Starte ich nun mehrere Downloads, Datentransfers kann ich den Datendurchsatz steigern!!!

Als Test habe ich mehrere Downloads von einem WebServer gestartet. Hierbei konnte ich bei 6 parallel laufenden Downloads im Durchschnitt 5,5 MByte/s (44 Mbit) und max 6,7 MByte/s (53,6 Mbit) erreichen. Gleiches Ergebnis kann ich über rsync oder AFTP reproduzieren.

Auf dem Pi erzeugte dies folgenden Auslastung:

CPU Auslastung (pro Kern): 44 %, Datendurchsatz: 4,0 MByte/s
CPU Auslastung (pro Kern): 55 -61 %, Datendurchsatz: 4,5 - 5,0 MByte/s
CPU Auslastung (pro Kern): 80 %, Datendurchsatz: 6,7 MByte/s

Das macht pro Datentransfer einen Durchsatz von 0,8 - 1,1 MByte/s

Was mich zu der Frage bringt, gibt es eine Limitierung pro Datentransfer (Session) auf dem easy2connect System / Feste-IP VPN Gateway? Irgendwer scheint hier ja den maximalen Datendurchsatz zu begrenzen...

Danke für Deine Mühe!

Vielleicht findet sich ja irgendwo eine Lösung!?! :D

Gruß
Tobias

P.S.: Ein Verbindungsproblem seitens meines Provides können wir wohl ausschließen!?

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 10.1.1x.xx netmask 255.255.255.0 broadcast 10.1.1x.255
inet6 fe80::xxxx:cexx:daxx:xxxx prefixlen 64 scopeid 0x20<link>
ether b8:27:eb:xx:xx:xx txqueuelen 1000 (Ethernet)
RX packets 7880246 bytes 1082984214 (1.0 GiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 18007231 bytes 2561906427 (2.3 GiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

tun0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST> mtu 1500
inet 10.19x.xx.xx netmask 255.255.255.255 destination 10.19x.xx.xx
inet6 fe80::ff79:7c0c:3c05:da07 prefixlen 64 scopeid 0x20<link>
unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 100 (UNSPEC)
RX packets 3538792 bytes 191762476 (182.8 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 6564616 bytes 9123314481 (8.4 GiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

tun100: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST> mtu 1440
inet 10.62.1xx.1xx netmask 255.255.255.255 destination 10.62.1xx.1xx
inet6 fe80::9582:6dba:f5c9:8c62 prefixlen 64 scopeid 0x20<link>
unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 100 (UNSPEC)
RX packets 1265927 bytes 353612631 (337.2 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 7369401 bytes 9666597054 (9.0 GiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

michael.esser
Beiträge: 8
Registriert: Mi 4. Jan 2017, 21:00

Re: VPN Perfomance

Beitrag von michael.esser » Sa 7. Apr 2018, 18:34

Hallo,

Dir fehlt eine globale ipv6 auf eth0.

Gruß,
Michael

goetzy
Beiträge: 10
Registriert: Di 13. Mär 2018, 18:18

Re: VPN Perfomance

Beitrag von goetzy » So 8. Apr 2018, 01:07

Hallo Michael,

vielleicht kannst Du kurz umreißen inwieweit oder warum eine globale IPv6 meine Performance Probleme lösen kann?

Danke für Deine Mühe!

Gruß
Tobias

michael.esser
Beiträge: 8
Registriert: Mi 4. Jan 2017, 21:00

Re: VPN Perfomance

Beitrag von michael.esser » So 8. Apr 2018, 01:44

Hallo,

Wie Michael Weigel gesagt hat: ipv6 Verbindungsprobleme. In diesem Fall gibt es gar keine. Sobald die Box diese hat sollte sich auch was bei der Geschwindigkeit tun. Versuch es mal.

Wenn Du möchtest hab ich Dir zum Test für ein paar Tage bei mir mal etwas gestartet ( pwd tobias ): 1x200mbit ohne und 1x200mbit mit dual stack @ Deutsche Glasfaser. Es macht mehr Sinn das Ganze hier anzuhängen aber damit hatte ich das letzte Mal meine Schwierigkeiten :(

Gruß,
Michael

goetzy
Beiträge: 10
Registriert: Di 13. Mär 2018, 18:18

Re: VPN Perfomance

Beitrag von goetzy » So 8. Apr 2018, 11:56

Hi Michael (Esser),

Ok, dann lag da wohl ein Verständnisproblem vor. :D

Ich hatte Michael (Weigel) so verstanden dass User die auf einem easy2connect System eine eine globale IPv6 (z.B. bei Unitymedia) binden unter verlorenen Pakete leider können (Zitat: Diese schlechte VPN Performance kommt meist von IPv6 Verbindungs-Problemen bei Unitymedia. (verlorene Pakete).). Und diese führen dann zu den Performance Problemen!

Hatte für mich dort auch kein Problem gesehen, da ich auf meinen lokalen Clients keine globale IPv6 nutze und über den IPv4 keine verlorenen Pakete gemeldet wurden, der VPN Tunnel im allgemeinen super funktioniert und ich in dem easy2connect Script keinen funktionellen Nachteile zwischen Lokaler IPv4 <-> IPv6 entdecken konnte.

Ich werde dem Client eine globale IPv6 Adresse zuweisen und Rückmeldung geben! :) Danke für den Tipp!!! :D

goetzy
Beiträge: 10
Registriert: Di 13. Mär 2018, 18:18

Re: VPN Perfomance

Beitrag von goetzy » Di 10. Apr 2018, 12:11

Hallo zusammen,

hab jetzt mal den Tipp umgesetzt der easy2connect Box eine globale IPv6 Adresse gegeben! Neustart der Box, Einwahl zu Feste-IP-net, Einwahl VPN Client auf easy2connect Box funktioniert...

Es ändert sich aber leider nichts an der Übertragungsgeschwindigkeit, es wird nicht die mögliche Bandbreite (begrenzt durch die CPU des Raspberry PI) ausgenutzt! Obwohl der Datentransfer laut "iftop" nun über IPv6 läuft, bemerke ich keine Verbesserung. :(


Auszug "iftop"

2a00:6020:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx => 2a0a:xxxx:0:xx:x::xxx 24,9Mb 14,6Mb 22,7Mb
<= 1,04Mb 873Kb 0,99Mb

Auszug "ifconfig"

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 10.1.xx.xx netmask 255.255.255.0 broadcast 10.1.xx.xxx
inet6 fe80::9bd2:ce11:dadb:6706 prefixlen 64 scopeid 0x20<link>
inet6 2a00:6020:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx prefixlen 64 scopeid 0x0<global>
ether b8:27:xx:xx:xx:xx txqueuelen 1000 (Ethernet)
RX packets 2805131 bytes 3369188018 (3.1 GiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 6269932 bytes 3977032329 (3.7 GiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


Auszug "Spendetest" vom Raspberry Pi

Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by LWLcom GmbH (Dusseldorf) [43.17 km]: 19.062 ms
Testing download speed................................................................................
Download: 114.51 Mbit/s
Testing upload speed....................................................................................................
Upload: 125.06 Mbit/s

Pro Datentransfer Session bekomme ich immer noch nur 0,8 - 1,1 MByte/s. Starte ich mehrere parallel, bekomme ich wie oben bereits beschrieben den PI ausgelastet...

P.S.: michael.esser, danke für den VPN Zugang, hab es leider noch nicht geschafft den zu testen... :D

Antworten