Zugriff per VNC auf FIP-Box via Portmapper

Alles Rund um die Einrichtung unserer IPv6 Portmapper
Antworten
Cudi
Beiträge: 4
Registriert: Fr 6. Feb 2015, 14:29

Zugriff per VNC auf FIP-Box via Portmapper

Beitrag von Cudi » Fr 6. Feb 2015, 15:47

Hallo Zusammen,

da dies meine erster Foreneintrag bei feste-ip.net ist, etwas Vorgeplänkel. 8-)

Erstmal möchte ich mich für den Service und den tollen Support (speziell bei Herrn Marticke) bedanken. :P

Meine Konfiguration (ISP, Portmapping-Gerät, ...) kann meiner Signatur entnommen werden. :!:

Nun zum tatsächlichen Problem:

Ich möchte per VNC auf die GUI des RPi (raspbian) zugreifen.
Ich habe den VNC-Server (tightvnc) installiert und kann netzintern mit 192.168.0.20:5901 darauf zugreifen.
Ich habe ein IPv6-Portmapping (Mein Account --> DynamischesDNS --> Hostname --> IPv6-Features) auf den Port 5901 eingerichtet.

In der Datei /etc/fipbox (aufgerufen mit fipedit) habe ich folgende Zeile eingetragen:

Code: Alles auswählen

#AKTIV#PORTMAPPER#5901#192.168.0.20#5901
Leider funktioniert der Zugang per VNC nicht.

netstat sagt mir für 5900 und 5901 folgendes:

Code: Alles auswählen

pi@fipbox ~ $ netstat -an | grep 5900
tcp6       0      0 :::5900                 :::*                    LISTEN     
pi@fipbox ~ $ netstat -an | grep 5901                                                                                    
tcp        0      0 0.0.0.0:5901            0.0.0.0:*               LISTEN  
Ich habe mittels fipedit einen lokalen Portmapper sowohl auf 127.0.0.1:5900 als auch auf 127.0.0.1:5901 gesetzt:

Code: Alles auswählen

#AKTIV#PORTMAPPER#5900#127.0.0.1#5900                                                                                    
#AKTIV#PORTMAPPER#5901#127.0.0.1#5901 
Leider war auch das ohne Erfolg.


Was kann ich noch tun, bzw. gibt es andere VNC-Server mit welchen ein zugriff auf die FIP-Box selbst funktioniert?

Anmerkung: Mein Windows-Rechner (Port 6900) ist via Portmapper problemlos erreichbar.
ISP: Kabel-BW (DS-Lite)
Modem: Technicolor TC7200
Portmapper: RaspberryPi 2 B (Quad-Core 900 MHz, 1GB RAM)

rema
Feste-IP.Net Support
Beiträge: 392
Registriert: Do 5. Feb 2015, 10:24

Re: Zugriff per VNC auf FIP-Box via Portmapper

Beitrag von rema » Fr 6. Feb 2015, 17:56

Hallo,

Der Eintrag per fipedit für den Port 5900 ist nicht notwendig, da der Server ja schon auf IPv6 lauscht.
Bitte mal mittels

Code: Alles auswählen

sudo apt-get install tcpdump
tcpdump installieren.
Dann mit

Code: Alles auswählen

sudo tcpdump -n port 5900
starten und prüfen ob bei dem Aufruf der Portmapperadresse im VNC der Traffic auf der FIP-Box ankommt.

ACHTUNG: Ports werden im VNC mit 2 Doppelpunkten angegeben !

Cudi
Beiträge: 4
Registriert: Fr 6. Feb 2015, 14:29

Re: Zugriff per VNC auf FIP-Box via Portmapper

Beitrag von Cudi » Fr 6. Feb 2015, 18:45

fipteam_rema hat geschrieben:Hallo,

Der Eintrag per fipedit für den Port 5900 ist nicht notwendig, da der Server ja schon auf IPv6 lauscht.
Bitte mal mittels

Code: Alles auswählen

sudo apt-get install tcpdump
tcpdump installieren.
Dann mit

Code: Alles auswählen

sudo tcpdump -n port 5900
starten und prüfen ob bei dem Aufruf der Portmapperadresse im VNC der Traffic auf der FIP-Box ankommt.

ACHTUNG: Ports werden im VNC mit 2 Doppelpunkten angegeben !
Ich bin was die Ports angeht momentan etwas verunsichert.

Wenn ich mit netzintern mit 192.168.0.20:5901 auf die FIP-Box zugreifen kann, ist der Port doch definitiv 5901 und nicht 5900 und für 5901 sagt:

Code: Alles auswählen

pi@fipbox ~ $ netstat -an | grep 5901                                                                                    
tcp        0      0 0.0.0.0:5901            0.0.0.0:*               LISTEN
also IPv4.

Ich würde gerne wissen warum er für 5900 IPv6 sagt...

Ich habe folgendes via fipedit entfernt und anschließend rebootet:

Code: Alles auswählen

#AKTIV#PORTMAPPER#5900#127.0.0.1#5900                                                                                    
#AKTIV#PORTMAPPER#5901#127.0.0.1#5901
Zugriff via de2.portmap64.net:PORT nicht möglich.

TCP dump sagt:

für Port 5901:

Code: Alles auswählen

pi@fipbox ~ $ sudo tcpdump -n port 5901                                                                                 
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode                                               
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes                                                 
17:43:07.794730 IP6 2a02:2260:1:1b90::8765.39277 > 2a02:8070:e190:3500:ba27:ebff:fe7c:5d9b.5901: Flags [S], seq 813705570
, win 14400, options [mss 1440,sackOK,TS val 1057137928 ecr 0,nop,wscale 3], length 0                                    
17:43:07.794977 IP6 2a02:8070:e190:3500:ba27:ebff:fe7c:5d9b.5901 > 2a02:2260:1:1b90::8765.39277: Flags [R.], seq 0, ack 8
13705571, win 0, length 0                                                                                                
^C                                                                                                                       
2 packets captured                                                                                                       
2 packets received by filter                                                                                             
0 packets dropped by kernel   


für Port 5900:

Code: Alles auswählen

pi@fipbox ~ $ sudo tcpdump -n port 5900                                                                                  
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode                                               
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes                                                 
17:43:54.469951 IP6 2a02:2260:1:1b90::8765.51648 > 2a02:8070:e190:3500:ba27:ebff:fe7c:5d9b.5900: Flags [S], seq 233905959
3, win 14400, options [mss 1440,sackOK,TS val 1057149597 ecr 0,nop,wscale 3], length 0                                   
17:43:54.470195 IP6 2a02:8070:e190:3500:ba27:ebff:fe7c:5d9b.5900 > 2a02:2260:1:1b90::8765.51648: Flags [R.], seq 0, ack 2
339059594, win 0, length 0
ISP: Kabel-BW (DS-Lite)
Modem: Technicolor TC7200
Portmapper: RaspberryPi 2 B (Quad-Core 900 MHz, 1GB RAM)

rema
Feste-IP.Net Support
Beiträge: 392
Registriert: Do 5. Feb 2015, 10:24

Re: Zugriff per VNC auf FIP-Box via Portmapper

Beitrag von rema » Mo 9. Feb 2015, 21:39

Die unterschiedlichen Ports geben die verschiedenen "Displays" vom VNC Server an.
die tcpdumps zeigen, dass der Traffi durch kommt.
Kannst du mal bitte versuchen einen internen Portmapper
5555:127.0.0.1:5901 anzulegen und einen externen auf den Port 5555.
Diesen dann noch im Router mit freigeben und nochmal testen.

Cudi
Beiträge: 4
Registriert: Fr 6. Feb 2015, 14:29

Re: Zugriff per VNC auf FIP-Box via Portmapper

Beitrag von Cudi » Mo 9. Feb 2015, 22:36

fipteam_rema hat geschrieben:Die unterschiedlichen Ports geben die verschiedenen "Displays" vom VNC Server an.
die tcpdumps zeigen, dass der Traffi durch kommt.
Kannst du mal bitte versuchen einen internen Portmapper
5555:127.0.0.1:5901 anzulegen und einen externen auf den Port 5555.
Diesen dann noch im Router mit freigeben und nochmal testen.
:D :D :D :D

Top!
Funktioniert einwandfrei!

Portfreigabe war nicht Mal nötig (Modem TC7200)

Vielen Dank für den Top Service!

Evtl. wäre es Sinnvoll eine Anleitung für "VNC auf FIP-Box" zu schreiben und auf der Webseite zu hinterlegen bzw. allgemein einen Forumspunkt mit Anleitungen.
ISP: Kabel-BW (DS-Lite)
Modem: Technicolor TC7200
Portmapper: RaspberryPi 2 B (Quad-Core 900 MHz, 1GB RAM)

rema
Feste-IP.Net Support
Beiträge: 392
Registriert: Do 5. Feb 2015, 10:24

Re: Zugriff per VNC auf FIP-Box via Portmapper

Beitrag von rema » Do 12. Feb 2015, 13:25

Danke für die Rückmeldung.
Wir wollten erstmal schauen wie sich das Forum entwicklt und nicht von Anfang an zig Unterforen erstellen.
Ich werde noch ein "How-TO Bereich erstellen. Dann kanns losgehen ;-)

Antworten