Seite 1 von 1

[gelöst] Zeitüberschreitung der Anforderung

Verfasst: Mo 6. Apr 2020, 22:31
von domidodo
Guten Tag,

ich habe meinen Raspberry Pi mithilfe der "FIP-VPN Verbindung" als Server im Internet.
Allerdings ist dieser nicht immer erreichbar.
In einem Moment funktioniert alles und in anderem erhate ich den Fehler der Zeitüberteitung.

Wenn ich über das lokale Netz auf ihn zugreife gibt es diese Probleme nie wordurch ich den Pi als Fehlerursache eigentlich ausgeschlossen habe.

Zwischen den beiden Ping`s auf dem Bild liegen villt 10 Sekunden.
Bild

:(

Jemand eine Idee woran das liegen könnte und wie es gelöst werden könnte?

UPDATE:
Ich habe die Verbindung zum Pi sowohol über die lokale als auch über die globale IP-Adresse getestet*. Rausgekommen ist folgendes:
Bild
*Alle 10 Sekunden wurde abwechselnt der Pi über die lokale und über die globale (VPN)-IP-Adresse angepingt. Ob der Ping erfolgreich war wurde protokolliert. Und mit einfacher Prozentrechnung die Zuverlässigkeit ermittelt.

Außerdem habe ich die ergebnisse in ein Zeitdiagreamm eingetragen welches folgendermaßen aussieht:
Bild


Es liegt also ziemlich sicher nicht am Pi.
Der Ausfall sieht regelmäßig und nicht willkürlich aus. :|

Re: Zeitüberschreitung der Anforderung

Verfasst: Di 14. Apr 2020, 18:17
von domidodo
Ich habe vom Support den hinweis bekommen, dass mein Pi immer wieder veruscht eine VPN-Verbindung aufzubauen obwohl er bereits verbunden ist.

Mit diesem Hinweis konnte das Problem schnell gelöst werden.
Ich hatte im „/etc/openvpn/“-Verzeichnis zum einen die .conf und eine Kopie von dieser welche als Sicherung gedacht war.
Durch den Autostart Befehl „AUTOSTART="all"“ in der „/etc/default/openvpn“-Datei wurden beide .conf`s erkannt und versucht zu starten.
Dies sorge dafür, dass veruscht wurde die selbe Verbindung 2x aufzubauen. Dies hat natürlich nicht funktioniert. Und sorge für die regelmäsigen Ausfälle.

Ich habe die Sicherheitskopie der .conf verschoben. Anschließend systemctl-daemon neu geladen und den openvpn Service neu gestartet.
Mein Test liefert mir nach über einer Stunde Testlaufzeit immer noch keine Abstürze. Also eine Zuverlässigkeit von 100%. Sehr schön. :D

Kurz die Befehle zum nachmachen:

Code: Alles auswählen

sudo cp /etc/openvpn/abc.conf /home/username/abc.conf
sudo rm -r /etc/openvpn/abc.conf
sudo systemctl daemon-reload
sudo service openvpn restart
Optional hätte man auch die openvpn-Datei anpassen können:

Code: Alles auswählen

sudo nano /etc/default/openvpn
------------------------
# AUTOSTART="all"
AUTOSTART="abc"  # Name der .conf
------------------------
sudo systemctl daemon-reload
sudo service openvpn restart