Fipbox Installationsskript Raspbian Stretch, Keine Netzwerkverbindung

Hilfe und Anleitungen Rund um den Einsatz unserer FIP-Box
Antworten
meiermanuel87
Beiträge: 1
Registriert: Mo 6. Aug 2018, 12:56

Fipbox Installationsskript Raspbian Stretch, Keine Netzwerkverbindung

Beitrag von meiermanuel87 » Mo 6. Aug 2018, 13:13

Hallo Zusammen,

ich habe leider ein Problem bei der Installation von Fipbox auf Raspbian Stretch.

Ich bin momentan dabei, auf einem Ubuntu NB in Virtualbox einen Raspi zu betreiben.
Heruntergeladen habe ich das Image hier: https://www.raspberrypi.org/downloads/r ... i-desktop/
Installation verläuft auch ohne Probleme.

In Virtualbox ist das Netzwerk auf Netzwerkbrücke eingestellt, damit ich dem Image eine andere IP Adresse geben kann.


Bis hier her funktioniert alles wie es soll.
Jetzt möchte ich Fipbox installieren, da ich bei mir zuhause einen DS Lite Anschluss habe, und diesen über OpenVPN erreichen möchte.
Ich konnte damals mit Raspian Jessy Fipbox ohne jegliche Probleme installieren, jetzt seit Stretch gibt es allerdings mit der Installation Probleme.
Ich gehe nach dieser Anleitung vor:
http://www.feste-ip.net/fip-box/basic/f ... tallieren/
Ich installiere das Skript, wie es auf der Internetseite zur Verfügung steht.

Sobald ich jetzt allerdings die Datei ausgeführt habe, ist keine Internetverbindung mehr möglich mit folgendem Fehler:


Kann es sein, dass mit der Umstellung auf Stretch irgendetwas mit den Netzwerkeinstellungen nicht mehr im Skript stimmt?
Hier kommt ich leider nicht mehr weiter.
Vielleicht kann mir hier jemand behilflich sein.

Danke
Dateianhänge
4.png
4.png (67.11 KiB) 146 mal betrachtet
3.png
3.png (32.13 KiB) 146 mal betrachtet
2.png
2.png (37.04 KiB) 146 mal betrachtet
1.png
1.png (40.17 KiB) 147 mal betrachtet

MichaelWeigel
Beiträge: 406
Registriert: Di 24. Feb 2015, 11:13

Re: Fipbox Installationsskript Raspbian Stretch, Keine Netzwerkverbindung

Beitrag von MichaelWeigel » Do 9. Aug 2018, 18:11

Hallo,

leider hat das Script noch ein Problem mit dem mit dem neuen Stretch. im Script wird in die Datei /etc/network/interfaces folgendes eingetragen:

Code: Alles auswählen

auto eth0:1
iface eth0:1 inet static
 address 172.16.254.1
 netmask 255.255.255.252
 broadcast 172.16.254.3
Das ist eigentlich eine Notfall IP ;) .
Bitte Löschen Sie diese Einträge aus der Datei und es geht alles wieder :D

Das Script zum Download wird noch geändert.

LG Michael

fullcane
Beiträge: 1
Registriert: Fr 28. Okt 2016, 13:41

Re: Fipbox Installationsskript Raspbian Stretch, Keine Netzwerkverbindung

Beitrag von fullcane » Mi 14. Nov 2018, 22:07

Hallo,

ich hatte das gleiche Problem und konnte es gleichfalls mit der Modifikation der Datei /etc/network/interfaces lösen. Allerdings tritt bei mir bei der anschließenden Installation von OPENVPN ein Fehler auf, dessen Ursache ich bis jetzt noch nicht lokalisieren konnte. Das Skript fipboxvpn.sh ist fehlerfrei durchgelaufen. Anschließend habe ich per Hand in der Datei '/etc/openvpn/server.conf' in der Zeile 'server' die eingetragene IP-Adresse durch die IP für den Adressraum meines lokalen Netzes ersetzt.

Beim anschließenden Neustart des RaspberryPi tritt folgende Fehlermeldung auf:
Failed to start /etc/rc.local Compatibility
Die Ausgabe von "systemctl systemctl status rc-local.service" besagt dazu
● rc-local.service - /etc/rc.local Compatibility
Loaded: loaded (/lib/systemd/system/rc-local.service; static; vendor preset: enabled)
Drop-In: /lib/systemd/system/rc-local.service.d
└─debian.conf
/etc/systemd/system/rc-local.service.d
└─ttyoutput.conf
Active: failed (Result: exit-code) since Wed 2018-11-14 20:11:59 UTC; 2min 36s ago
CPU: 72ms

Nov 14 20:11:59 fipbox systemd[1]: Starting /etc/rc.local Compatibility...
Nov 14 20:11:59 fipbox INADYN[575]: Wed Nov 14 20:11:59 2018: E:CACHE_LIST Failed opening cache file in ip_cache_list_read...
Nov 14 20:11:59 fipbox INADYN[575]: Wed Nov 14 20:11:59 2018: W:IP: Error 0x6f resolving host name 'google.com'
Nov 14 20:11:59 fipbox INADYN[575]: Wed Nov 14 20:11:59 2018: W:DYNDNS: Error 'RC_ERROR' (0x1) when talking to IP server
Nov 14 20:11:59 fipbox rc.local[559]: bind: Address already in use
Nov 14 20:11:59 fipbox systemd[1]: rc-local.service: Control process exited, code=exited status=1
Nov 14 20:11:59 fipbox systemd[1]: Failed to start /etc/rc.local Compatibility.
Nov 14 20:11:59 fipbox systemd[1]: rc-local.service: Unit entered failed state.
Nov 14 20:11:59 fipbox systemd[1]: rc-local.service: Failed with result 'exit-code'.
Wenn ich mich per SSH auf den Raspberry einlogge, bekomme ich nur noch ein Ping von der FRITZ!Box, aber sonst keinem Netzwerkgerät. Pings- auf externe Adressen funktionieren auch nicht mehr.

Trotzdem kann ich mit einem Client von außen eine VPN-Verbindung zum OPENVPN-Server auf dem Raspberry herstellen. Wenn die Verbindung hergestellt ist, komme ich aber weder auf die FRITZ!Box, noch auf andere Geräte im lokalen Netz.

Meine Konfiguration:

RaspberryPi Modell 3B
Operating System: Raspbian GNU/Linux 9 (stretch)
Kernel: Linux 4.14.50-v7+

Für den Fall dass es hilft hier noch die Ausgabe von ifconfig:
br0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.178.29 netmask 255.255.255.0 broadcast 192.168.178.255
inet6 2a02:908:69c:36a0:ba27:ebff:fed7:86ac prefixlen 64 scopeid 0x0<global>
inet6 fe80::ba27:ebff:fed7:86ac prefixlen 64 scopeid 0x20<link>
ether b8:27:eb:d7:86:ac txqueuelen 1000 (Ethernet)
RX packets 7571 bytes 846389 (826.5 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3814 bytes 385683 (376.6 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
ether b8:27:eb:d7:86:ac txqueuelen 1000 (Ethernet)
RX packets 8449 bytes 992591 (969.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3910 bytes 427096 (417.0 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 113 bytes 9326 (9.1 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 113 bytes 9326 (9.1 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

tun0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST> mtu 1500
inet 192.168.178.1 netmask 255.255.255.255 destination 192.168.178.2
inet6 fe80::fe6a:960a:f680:8066 prefixlen 64 scopeid 0x20<link>
unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 100 (UNSPEC)
RX packets 491 bytes 33225 (32.4 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 109 bytes 8787 (8.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
Hat vielleicht jemand eine Idee, wo der Kern des Übels zu finden ist und wie man das Problem lösen kann.

Vielen Dank
fullcane

Antworten