Teilweise Funktionsverlust 10 Minuten nach IP-Update (SSH, OpenVPN, ipv6)

Hilfe bei der Einrichtung unsere DDNS Dienste in Routern und anderen Geräte sowie Updateclients
Antworten
X-Ray
Beiträge: 1
Registriert: Do 10. Jan 2019, 08:52

Teilweise Funktionsverlust 10 Minuten nach IP-Update (SSH, OpenVPN, ipv6)

Beitrag von X-Ray » Do 10. Jan 2019, 11:51

Guten Tag zusammen,

mein Konfiguration zeigt ein merkwürdiges Verhalten, dass ich mir nicht erklären kann. Vielleicht weiß jemand, ob es sich um einen Bug oder eine Fehlkonfiguration meinerseits handelt.
Folgendermaßen ist mein Setup:

- Zu Hause, hinter einem Unitymedia-Kabelanschluss (DS-Lite, Fritz!Box 6590) läuft ein Pi.
- Bei FIP habe ich einen DDNS-Host mit zwei Protmappings unter "IPv6 Features" laufen (ein Port für SSH, nein nicht 22, und einer für OpenVPN).
- Die entsprechenden Ports sind in der Fritzbox für IPv4 und IPv6 freigegeben.
- Der Pi macht per curl cron job in festen Zeitabständen IP-Update-Queries an v6.members.feste-ip.net.

- Wenn ich im FIP-Konto unter "IPv6 Features" auf die beiden Ports klicke, bekomme ich für beide "Port erreichbar" angezeigt (funktioniert dauerhaft).
- VPN-Verbindungen aus dem Mobilfunknetz (bekanntermaßen IPv4) funktionieren tadellos.

Jetzt das Skurrile:

Eine SSH-Verbindung kann ich nur kurz nach einem IP-Update mit Änderung (good) herstellen (von unterschiedlichen Clients aus getestet). Nach einer gewissen Zeit sind keine Verbindungsherstellungen mehr möglich (connection timeout). Der Port ist aber im FIP-Konto weiterhin erreichbar. Wenn ich dann die IP-Adresse des DDNS-Hosts ändere und anschließend wieder auf die vom Pi zurückstelle (per FIP-Kto oder curl), kann ich erneut eine SSH-Verbindung aufbauen.
Außerdem scheint die Update-Query des Pi ohne Änderung (nochg) einen Verbindungsabbruch bei bestehenden SSH-Verbindungen zu verursachen (ganz sicher bin ich mir nicht, ich hatte auch schon Verbindungsabbrüche, ohne dass eine Update-Query ausgelöst wurde).

Edit:
Die Verbindungsabbrüche bestehender SSH-Verbindungen scheinen doch nicht mit den Update-Queries in Zusammenhang zu stehen. Mehrere Tests zeigten, dass die SSH-Verbindung immer 11 bis 12 Sekunden nach vollen 10 Minuten (also bspw. 10:30:11, 15:50:12, 18:10:11, ...) auftreten. Da ich auf dem Pi keinen Cron-Timer mit 10-Min-Intervall laufen habe, vermute ich, dass die Ursache woanders liegt.

Edit #2:
Wenn ich für die IPv6 des Pi einen "Universellen Portmapper" einrichte und mich mit diesem verbinde, bleibt die Verbindung zuverlässig bestehen.

Ich danke im Voraus
Ralf

Antworten