Router-FIPbox Apache-Webserver

In diesem Forum können Sie ihre allgemeine Anfragen zu Realisierungswünschen bzw. Machbarkeiten stellen.
Anfragen zu speziellen Produkten stellen Sie bitte direkt in dem jeweiligen Unterforum.
Post Reply
Benjoire
Posts: 1
Joined: Sun 22. Jan 2023, 13:38

Router-FIPbox Apache-Webserver

Post by Benjoire »

Hallo,

ich habe das FIP-Kit gekauft, um die rotierende IP des T-Speedports zu umgehen.
Bislang musste ich die geänderte WAN-IP des Speedport in den A-Records meiner Domain-Provider (Namecheap, united-domains) angleichen.
Nur so konnte der Apache-Server mit verschiedenen Virtual-Hosts erreichbar gemacht werden. Nicht zu vergessen die Portweiterleitung seitens des Routers zur Linux-Maschine mit dem Apache-Webserver.

Nun habe ich die SD-Karte in den RaspberryPi eingelegt... und natürlich zuvor den Tarif freigeschaltet. Den Rpi4 an den Router gesetzt und die Stromversorgung angeschlossen (zum ersten mal einen Rp4 in den Händen).
leere Zeile

...schon leuchtet die Diode am Rpi4 ROT! Ich super glücklich, wie ich über einen Browser die 'PortUnity' (toller Unternehmens-Name, gegeben das Logo mit einer angedeuteten habitablen Zone?!) Rpi4-Oberfläche erreiche. Hier scheint alles i.O., LAN-, Tunnel-Status "Verbunden".
Vom selben Router ausgehend, verbinde ich zwei Maschinen über einen simplen Switch/Hub. MS-Windows und Debian-Linux. Beide Maschinen können ein Ping-Signal vom Rpi4 empfangen (aber nicht umgekehrt, Pingtest-Tool). Optimistisch und voller Stolz auf die Portunity-Crew beginne ich meine "Konfiguration".

Schnell merke ich, dass ich den Rpi4 so einfach gar nicht ausschalten kann. Putty und Linux-Terminal verweigern mir trotz mehrfacher Passwort Ein-/Neuvergabe einen Zugriff. Das Browser-Dashboard erlaubt (sinnvollerweise) lediglich das Auslesen der IPs, PW-Vergabe, Netzwerk-Konfigs.
Ich schreibe dies so ausführlich, damit vllt. jemand die Pointe versteht. Das Rpi4 wurde ohne Monitor-HDMI-Verbindung gebootet, was bedeutet, dass die HDMI-SchnittstelleN desaktiviert sind. Jaja, lange Rede kurzer Sinn: I'm stuck in the middle of the needle. Vielleicht weiß hier jemand schnell eine Lösung.

P.S.: Das Handbuch ist quasi nicht existent, soweit kein Problem; für IT-Savants. Nur, wollte ich meine FIP-Box an den Router anschliessen, den A-Record bei den Domain-Providern auf eine der festen/statischen (dynam-offensiven, Stichwort "Trapattoni") setzen und voilá...
leere Zeile (intentionally)
[Edit: Habe gerade das Standardwerk der Portweiterleitung vor mir auf dem Bildschirm. https://www.feste-ip.net/fileadmin/FIP-Book.pdf :oops: ]
Ja nun, eine Portweiterleitung statt direkt auf die Server-Maschine, zunächst auf den Rpi4 und von dort auf die Server-Maschine ist wahrscheinlich notwendige Schaltungslogik. Ich fange gerade erst an, von Webdesign auf Informationstechnologie upzugraden.

Soll ich den Rpi4 einfach vom Strom nehmen? Da die Diode ROT leuchtet, so dachte ich, wäre es nützlich ein paar Terminal-Komandos zur Diagnose einzugeben.

LG Ben
MichaelWeigel
Posts: 770
Joined: Tue 24. Feb 2015, 11:13

Re: Router-FIPbox Apache-Webserver

Post by MichaelWeigel »

Hallo,

Es gibt kein FIP-Kit bei Feste-ip.net.? Es war wohl eine SD-Karte. Zu der SD-Karte wird immer auch ein Handbuch mitgeliefert. Nach dem Einbau der SD-Karte in den Raspberry PI muss die easy2connect ID im Account bei Feste-IP registriert werden. Dann können die gewünschten Freigaben gemacht werden.
LG Michael
Post Reply